summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-01-27 17:53:38 +0100
committerraveit65 <[email protected]>2020-01-31 21:13:59 +0100
commit7f41f1e9cc0c93d404e82b694d07070b46650a1d (patch)
treea5a1eda9fcfceac0cf82cccce7b8527d9e9f19e2 /configure.ac
parent89ec6dd6bc5daa8c67c75e836c613a71d8d6a486 (diff)
downloadlibmatekbd-7f41f1e9cc0c93d404e82b694d07070b46650a1d.tar.bz2
libmatekbd-7f41f1e9cc0c93d404e82b694d07070b46650a1d.tar.xz
Use gresources for UI files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d88e77..33ef625 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,27 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext package])
AM_GNU_GETTEXT_VERSION([0.19.8])
AM_GNU_GETTEXT([external])
+
+# **********************
+# GLIB_COMPILE_RESOURCES
+# **********************
+
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# *******
+# XMLLINT
+# *******
+
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
# *****************************************************************************
AC_CHECK_FUNCS(setlocale)