summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e89416f
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_PREREQ(2.54)
+AC_INIT([mate-common], [1.5.1], [https://github.com/mate-desktop/mate-common])
+
+AC_CONFIG_SRCDIR([macros/mate-autogen])
+
+AM_INIT_AUTOMAKE([1.9 foreign no-dist-gzip dist-bzip2])
+
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([no])])
+
+if test -z "$enable_maintainer_mode"; then
+ enable_maintainer_mode=yes
+fi
+
+AM_MAINTAINER_MODE([enable])
+
+AC_CONFIG_FILES([
+Makefile
+macros/Makefile
+doc-build/Makefile
+doc-build/mate-doc-common
+doc/Makefile
+])
+
+AC_OUTPUT