summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 399fb83..65faf6d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,3 +1,14 @@
-bin_SCRIPTS = mate-gsettings-toggle.sh
+bin_SCRIPTS = mate-gsettings-toggle
-EXTRA_DIST = $(bin_SCRIPTS)
+if MATE_CONF_IMPORT_ENABLED
+@INTLTOOL_DESKTOP_RULE@
+
+desktopdir = $(datadir)/applications
+desktop_in_files = mate-conf-import.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+bin_SCRIPTS += mate-conf-import
+endif
+
+EXTRA_DIST = $(bin_SCRIPTS)
+
+CLEANFILES = mate-conf-import.desktop