summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 11 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 357ee37..c1a6956 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,23 +16,20 @@ mozo: mozo.in
mozo: Makefile
EXTRA_DIST = \
- mozo.in \
- MAINTAINERS \
- ChangeLog.pre-git
+ mozo.in
ChangeLog:
- @echo Creating $@
- @if test -d "$(srcdir)/.git"; then \
- (GIT_DIR=$(top_srcdir)/.git ./missing --run git log git-migration.. --stat -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
- && mv -f [email protected] $@ \
- || ($(RM) [email protected]; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
else \
- test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
+ echo A git clone is required to generate a ChangeLog >&2; \
fi
.PHONY: ChangeLog
-