summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-06 19:44:52 +0200
committerraveit65 <[email protected]>2016-04-06 19:44:52 +0200
commit21fd7e4318b51d8839214d67fe81c8c8f142c6eb (patch)
treeaa9bf67aa806da953eee84aa7d21a7faed240000 /Makefile.am
parent325389d950fc4b5aa02734a92c6e37ad90eb39ca (diff)
downloadatril-21fd7e4318b51d8839214d67fe81c8c8f142c6eb.tar.bz2
atril-21fd7e4318b51d8839214d67fe81c8c8f142c6eb.tar.xz
Fix Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 014c6714..776982f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,18 +86,14 @@ DISTCHECK_CONFIGURE_FLAGS = \
distuninstallcheck_listfiles = find . -type f -print | grep -v /share/mate/help/ | grep -v \.omf
-dist-hook:
- @if test -d "$(srcdir)/.git"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
- || ( rm -f ChangeLog.tmp ; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo A git clone is required to generate a ChangeLog >&2; \
- fi
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
-include $(top_srcdir)/git.mk