summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <[email protected]>2012-06-10 16:05:59 +0200
committerraveit65 <[email protected]>2018-03-21 06:56:34 +0100
commit3f48838e6f469e5090a0b95864c298736b3b4e4f (patch)
treeb0dfdab3459ef977de03923c3e6a4c58929bb231 /configure.ac
parente51014b5a0b2750df5ccfe98696227c949c93c28 (diff)
downloadatril-3f48838e6f469e5090a0b95864c298736b3b4e4f.tar.bz2
atril-3f48838e6f469e5090a0b95864c298736b3b4e4f.tar.xz
shell: Use gdbus-codegen for the org.mate.atril.Application interface
origin commit: https://git.gnome.org/browse/evince/commit/?h=gnome-3-6&id=c9aada8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d85c7690..45836282 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,9 +144,15 @@ AS_IF([test "x$found_zlib" = "xno"], [
AC_SUBST(ZLIB_LIBS)
])
-dnl
-dnl SM client
-dnl
+AC_ARG_VAR([GDBUS_CODEGEN],[the gdbus-codegen programme])
+AC_PATH_PROG([GDBUS_CODEGEN],[gdbus-codegen],[])
+if test -z "$GDBUS_CODEGEN"; then
+ AC_MSG_ERROR([gdbus-codegen not found])
+fi
+
+ # *********
+ # SM client
+ # *********
PKG_CHECK_MODULES([SMCLIENT],[gtk+-3.0 gthread-2.0 sm >= 1.0.0])
AC_SUBST([SMCLIENT_CFLAGS])