summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPablo Barciela <[email protected]>2019-08-31 21:52:21 +0200
committerlukefromdc <[email protected]>2019-09-08 21:29:36 +0000
commitfe6a85533ba08ec7ea3f4cee139e10c76363288a (patch)
tree39bb8f0641b5f274b06a9c9daaa934f80fa0f70e /configure.ac
parentedd3661daf0c834881c59531bb52b42351b5afd2 (diff)
downloadatril-fe6a85533ba08ec7ea3f4cee139e10c76363288a.tar.bz2
atril-fe6a85533ba08ec7ea3f4cee139e10c76363288a.tar.xz
remove 'synctex' internally, work with external library instead
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ccc0fc25..5ee6d51a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -361,16 +361,14 @@ AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
dnl ================== libsynctex ===========================================
-PKG_CHECK_MODULES(SYNCTEX, [synctex >= $SYNCTEX_REQUIRED], has_synctex=system, has_synctex=internal)
+PKG_CHECK_MODULES(SYNCTEX, [synctex >= $SYNCTEX_REQUIRED], has_synctex=yes, has_synctex=no)
dnl not found? use internal code copy.
-if test "x$has_synctex" = "xinternal"; then
- SYNCTEX_LIBS="\$(top_builddir)/cut-n-paste/synctex/libsynctex.la"
- SYNCTEX_CFLAGS="-I\$(top_srcdir)/cut-n-paste/synctex"
+if test "x$has_synctex" = "xno"; then
+ AC_MSG_ERROR("SyncTeX support is disabled since library version $SYNCTEX_REQUIRED or newer not found")
fi
AC_SUBST(SYNCTEX_LIBS)
AC_SUBST(SYNCTEX_CFLAGS)
-AM_CONDITIONAL(USE_INTERNAL_SYNCTEX, test x$has_synctex = xinternal)
dnl ================== portability checks ===========================================
@@ -706,7 +704,6 @@ cut-n-paste/Makefile
cut-n-paste/smclient/Makefile
cut-n-paste/toolbar-editor/Makefile
cut-n-paste/zoom-control/Makefile
-cut-n-paste/synctex/Makefile
data/atril.desktop.in
data/Makefile
data/icons/Makefile