summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 15 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index 7370019a..57e68190 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,8 +51,7 @@ EXTRA_DIST = \
$(intltool_extra) \
$(header_DATA) \
autogen.sh \
- mate-doc-utils.make \
- MAINTAINERS
+ mate-doc-utils.make
DISTCLEANFILES = \
mate-doc-utils.make \
@@ -86,7 +85,7 @@ MAINTAINERCLEANFILES = \
`find "$(srcdir)" -type f -name Makefile.in -print`
DISTCHECK_CONFIGURE_FLAGS = \
- --disable-schemas-install \
+ --disable-schemas-compile \
--disable-scrollkeeper \
--enable-gtk-doc \
--disable-caja \
@@ -96,24 +95,18 @@ DISTCHECK_CONFIGURE_FLAGS = \
# Ignore scrollkeeper issues for now. @#*$& scrollkeeper
distuninstallcheck_listfiles = find . -type f -print | grep -v scrollkeeper | grep -v /share/mate/help/ | grep -v \.omf
-distclean-local: \
- if test "$(srcdir)" = "."; then :; else \
- rm -f ChangeLog; \
- fi
-
-ChangeLog: \
- $(AM_V_GEN) if test -d "$(srcdir)/.git"; then \
- (GIT_DIR=$(top_srcdir)/.git ./missing --run git log -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
- && mv -f [email protected] $@ \
- || ($(RM) [email protected]; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git log is required to generate this file >> $@)); \
- else \
- test -f $@ || \
- (echo A git checkout and git log is required to generate ChangeLog >&2 && \
- echo A git checkout and git log is required to generate this file >> $@); \
- fi
-
-.PHONY: ChangeLog
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi
-include $(top_srcdir)/git.mk