summaryrefslogtreecommitdiff
path: root/backend/epub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backend/epub/Makefile.am')
-rw-r--r--backend/epub/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/backend/epub/Makefile.am b/backend/epub/Makefile.am
index 9eca6519..e1dee6ca 100644
--- a/backend/epub/Makefile.am
+++ b/backend/epub/Makefile.am
@@ -15,7 +15,7 @@ backend_LTLIBRARIES = libepubdocument.la
libepubdocument_la_SOURCES = \
epub-document.c \
- epub-document.h
+ epub-document.h
libepubdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libepubdocument_la_LIBADD = \
@@ -29,7 +29,11 @@ backend_in_files = epubdocument.atril-backend.desktop.in
backend_DATA = $(backend_in_files:.atril-backend.desktop.in=.atril-backend)
$(backend_DATA): $(backend_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=TypeDescription --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
EXTRA_DIST = $(backend_in_files)