summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e7a63fee..ee33f27d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,9 +362,12 @@ AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
dnl ================== libsynctex ===========================================
AC_ARG_ENABLE([synctex],
- [AS_HELP_STRING([--disable-synctex], [Disable support for synctex])],
- [],
- [enable_synctex=yes])
+ [--enable-synctex enable support for synctex)],
+ [case "${enableval}" in
+ yes) synctex=true ;;
+ no) synctex=false;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-synctex]) ;;
+ esac],[enable_synctex=yes])
if test "$enable_synctex" = "yes"; then