summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSander Sweers <[email protected]>2013-10-31 02:43:14 +0100
committerStefano Karapetsas <[email protected]>2013-10-31 09:34:08 +0100
commit45ebe862780045591b39b731ec02a353b69a0a41 (patch)
treea43b869cadd68534d2386fb10a51e10402a81bcf /Makefile.am
parent11e5ff92dd0725ad604c9a716882a3d2c95c6414 (diff)
downloadcaja-extensions-45ebe862780045591b39b731ec02a353b69a0a41.tar.bz2
caja-extensions-45ebe862780045591b39b731ec02a353b69a0a41.tar.xz
Add options to dis/enable plugins, default build all
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 21 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index b95c1db..6348395 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,27 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --with-cajadir='$${libdir}/caja/extensions-2.0-distcheck'
-SUBDIRS = \
- po \
- gksu \
- image-converter \
- open-terminal \
- sendto \
- share
+SUBDIRS = po
+
+if ENABLE_OPEN_TERMINAL
+SUBDIRS += open-terminal
+endif
+
+if ENABLE_SENDTO
+SUBDIRS += sendto
+endif
+
+if ENABLE_IMAGE_CONVERTER
+SUBDIRS += image-converter
+endif
+
+if ENABLE_GKSU
+SUBDIRS += gksu
+endif
+
+if ENABLE_SHARE
+SUBDIRS += share
+endif
EXTRA_DIST = \
intltool-extract.in \