summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Brielmaier <[email protected]>2019-07-30 15:20:18 +0200
committerMartin Wimpress <[email protected]>2019-08-18 21:14:45 +0100
commit45d85850235bbcb6b59b1443d22f0e8203cce566 (patch)
tree362a0b33a9114b3e27af63eec1b41646d540e058 /configure.ac
parent9535aeeb72d9f0496df0188d9ffb92c1a3939745 (diff)
downloadcaja-extensions-45d85850235bbcb6b59b1443d22f0e8203cce566.tar.bz2
caja-extensions-45d85850235bbcb6b59b1443d22f0e8203cce566.tar.xz
Build either with gupnp version 1.0 or 1.2.
This fixes https://github.com/mate-desktop/caja-extensions/issues/52. * (configure.ac): Check also for gupnp-1.2 and set HAS_GUPNP_VERSION_1_2 to yes if found. * (sendto/plugins/upnp/upnp.c): Use gupnp_context_manager_create when building with gupnp-1.2 as gupnp_context_manager_new was removed. Signed-off-by: Jonathan Brielmaier <[email protected]> Co-authored-by: Gianfranco Costamagna <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 96b3578..0594115 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,8 @@ if test "x$enable_sendto" = "xyes"; then
fi
;;
upnp)
+ PKG_CHECK_MODULES(UPNP, gupnp-1.2 >= $GUPNP_REQUIRED,
+ enable_upnp=yes AC_DEFINE([HAS_GUPNP_VERSION_1_2], 1, ["Version is at least 1.2"]), enable_upnp=no)
PKG_CHECK_MODULES(UPNP, gupnp-1.0 >= $GUPNP_REQUIRED,
enable_upnp=yes, enable_upnp=no)
if test "${enable_upnp}" != "yes" ; then