summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-01-26 13:02:18 +0100
committerraveit65 <[email protected]>2020-02-10 00:37:02 +0100
commite713760554c0b130b6d3b7e46e2a91746b894224 (patch)
treebdb68464c495388666c507bbd5bd27403d596427 /configure.ac
parenta956971b492c65c452dbab46bb81cafb9e0e85d0 (diff)
downloadcaja-extensions-e713760554c0b130b6d3b7e46e2a91746b894224.tar.bz2
caja-extensions-e713760554c0b130b6d3b7e46e2a91746b894224.tar.xz
sendto: use gresources for UI files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1035c98..be4b68d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,22 @@ fi
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
+# GLIB_COMPILE_RESOURCES
+
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# XMLLINT
+
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
# Common requirements
PKG_CHECK_MODULES(CAJA,
libcaja-extension >= $CAJA_REQUIRED)