summaryrefslogtreecommitdiff
path: root/sendto/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-01-27 12:53:27 +0100
committerraveit65 <[email protected]>2020-02-29 21:23:50 +0100
commit0d372c1a0ae345d8ebbc69c52e9d55165e766109 (patch)
treea19c197a9c087253afa045dfb603c72d6a27ffc3 /sendto/Makefile.am
parenta53a6e6bc6ac5092e82ae493520b1538c6ccc304 (diff)
downloadcaja-extensions-0d372c1a0ae345d8ebbc69c52e9d55165e766109.tar.bz2
caja-extensions-0d372c1a0ae345d8ebbc69c52e9d55165e766109.tar.xz
automake: do not include CFLAGS in CPPFLAGS
Diffstat (limited to 'sendto/Makefile.am')
-rw-r--r--sendto/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/sendto/Makefile.am b/sendto/Makefile.am
index df02252..e23cde8 100644
--- a/sendto/Makefile.am
+++ b/sendto/Makefile.am
@@ -1,17 +1,20 @@
-NULL=
-
+NULL =
SUBDIRS = . docs plugins
AM_CPPFLAGS = \
+ $(DISABLE_DEPRECATED_CPPFLAGS) \
-DDATADIR=\"$(datadir)\" \
-DPLUGINDIR=\"$(libdir)/caja-sendto/plugins\" \
+ -DMATELOCALEDIR="\"$(datadir)/locale\"" \
-I$(top_srcdir) \
-I$(top_builddir) \
- -DLOCALEDIR="\"$(datadir)/locale\"" \
- $(SENDTO_CFLAGS) \
- $(CAJA_CFLAGS) \
- $(DISABLE_DEPRECATED) \
- $(WARN_CFLAGS)
+ $(NULL)
+
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(SENDTO_CFLAGS) \
+ $(CAJA_CFLAGS) \
+ $(NULL)
caja_sendto_includedir = $(includedir)/caja-sendto/
caja_sendto_include_HEADERS = caja-sendto-plugin.h
@@ -21,7 +24,7 @@ pkgconfig_DATA = caja-sendto.pc
noinst_LTLIBRARIES = libnstplugin.la
libnstplugin_la_SOURCES = \
- caja-sendto-plugin.h \
+ caja-sendto-plugin.h \
nst-enum-types.c \
nst-enum-types.h
libnstplugin_la_LIBADD = $(SENDTO_LIBS)