summaryrefslogtreecommitdiff
path: root/open-terminal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'open-terminal/Makefile.am')
-rw-r--r--open-terminal/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/open-terminal/Makefile.am b/open-terminal/Makefile.am
new file mode 100644
index 0000000..d5aabe8
--- /dev/null
+++ b/open-terminal/Makefile.am
@@ -0,0 +1,39 @@
+AM_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"Caja-Open-Terminal\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS) \
+ $(CAJA_CFLAGS) \
+ $(OPENTERMINAL_CFLAGS)
+
+caja_extensiondir=$(CAJA_EXTENSION_DIR)
+
+caja_extension_LTLIBRARIES=libcaja-open-terminal.la
+
+libcaja_open_terminal_la_SOURCES = \
+ caja-open-terminal.c \
+ caja-open-terminal.h \
+ open-terminal.c
+
+libcaja_open_terminal_la_LDFLAGS = -module -avoid-version
+libcaja_open_terminal_la_LIBADD = $(CAJA_LIBS) $(OPENTERMINAL_LIBS)
+
+gsettings_schemas_in_files = org.mate.caja-open-terminal.gschema.xml.in
+gsettings_SCHEMAS = $(gsettings_schemas_in_files:.gschema.xml.in=.gschema.xml)
+
+@INTLTOOL_XML_NOMERGE_RULE@
+
+@GSETTINGS_RULES@
+
+convertdir = $(datadir)/MateConf/gsettings
+convert_DATA = caja-open-terminal.convert
+
+DISTCLEANFILES = \
+ org.mate.caja-open-terminal.gschema.xml
+
+EXTRA_DIST = \
+ $(convert_DATA) \
+ $(gsettings_schemas_in_files) \ No newline at end of file