summaryrefslogtreecommitdiff
path: root/sendto/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sendto/plugins/Makefile.am')
-rw-r--r--sendto/plugins/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/sendto/plugins/Makefile.am b/sendto/plugins/Makefile.am
index 10097e8..6d17c98 100644
--- a/sendto/plugins/Makefile.am
+++ b/sendto/plugins/Makefile.am
@@ -1,16 +1,13 @@
-SUBDIRS = . \
- caja-burn \
- emailclient \
- gajim \
- pidgin \
- removable-devices \
- upnp
+SUBDIRS = . $(SENDTO_PLUGINS)
+DIST_SUBDIRS = $(ALL_SENDTO_PLUGINS)
NST_COMMON_SOURCES = nst-common.c nst-common.h
+if HAVE_GIO
noinst_LTLIBRARIES = libnstcommon.la
libnstcommon_la_SOURCES = $(NST_COMMON_SOURCES)
libnstcommon_la_CFLAGS = $(SENDTO_CFLAGS)
libnstcommon_la_LIBADD = $(SENDTO_LIBS)
+endif
EXTRA_DIST = $(NST_COMMON_SOURCES)