summaryrefslogtreecommitdiff
path: root/sendto/plugins/caja-burn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sendto/plugins/caja-burn/Makefile.am')
-rw-r--r--sendto/plugins/caja-burn/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/sendto/plugins/caja-burn/Makefile.am b/sendto/plugins/caja-burn/Makefile.am
new file mode 100644
index 0000000..50c309b
--- /dev/null
+++ b/sendto/plugins/caja-burn/Makefile.am
@@ -0,0 +1,19 @@
+plugindir = $(libdir)/caja-sendto/plugins
+
+AM_CPPFLAGS = \
+ -DDATADIR=\"$(datadir)\" \
+ -DICONDIR=\"$(icondir)\" \
+ -DLOCALEDIR="\"$(datadir)/locale\"" \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ -I$(srcdir)/../ \
+ $(SENDTO_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+plugin_LTLIBRARIES = libnstburn.la
+
+libnstburn_la_SOURCES = caja-burn.c
+libnstburn_la_LDFLAGS = -module -avoid-version
+libnstburn_la_LIBADD = $(SENDTO_LIBS) $(builddir)/../libnstcommon.la
+