summaryrefslogtreecommitdiff
path: root/sendto/plugins/pidgin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sendto/plugins/pidgin/Makefile.am')
-rw-r--r--sendto/plugins/pidgin/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sendto/plugins/pidgin/Makefile.am b/sendto/plugins/pidgin/Makefile.am
new file mode 100644
index 0000000..b7f650a
--- /dev/null
+++ b/sendto/plugins/pidgin/Makefile.am
@@ -0,0 +1,18 @@
+plugindir = $(libdir)/caja-sendto/plugins
+
+AM_CPPFLAGS = \
+ -DDATADIR=\"$(datadir)\" \
+ -DICONDIR=\"$(icondir)\" \
+ -DLOCALEDIR="\"$(datadir)/locale\"" \
+ -I$(top_srcdir)/sendto \
+ -I$(top_builddir) \
+ $(SENDTO_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+plugin_LTLIBRARIES = libnstpidgin.la
+
+libnstpidgin_la_SOURCES = pidgin.c
+libnstpidgin_la_LDFLAGS = -module -avoid-version
+libnstpidgin_la_LIBADD = $(SENDTO_LIBS)
+