summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-09-19 21:26:01 +0200
committerVictor Kareh <[email protected]>2019-10-01 22:06:07 -0400
commit610d0a08d8cb2dea6d380a5bffe6179fdd423589 (patch)
treec7c15154b9f2a19900123177a21e3d5667edf50d /src/Makefile.am
parentf70a69eb07d5b240f1ca7b53bf42077702cded01 (diff)
downloadengrampa-610d0a08d8cb2dea6d380a5bffe6179fdd423589.tar.bz2
engrampa-610d0a08d8cb2dea6d380a5bffe6179fdd423589.tar.xz
Remove internal mkdtemp and define feature test macro
mkdtemp(): /* Since glibc 2.19: */ _DEFAULT_SOURCE || /* Glibc 2.19 and earlier: */ _BSD_SOURCE || /* Since glibc 2.10: */ _POSIX_C_SOURCE >= 200809L _POSIX_C_SOURCE 200809L is enabled by _XOPEN_SOURCE >= 700. Ref: http://man7.org/linux/man-pages/man7/feature_test_macros.7.html
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f0cd3e7..1f125f8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,12 +6,6 @@ bin_PROGRAMS = engrampa
libexec_PROGRAMS = engrampa-server
noinst_PROGRAMS = test-server
-if MKDTEMP_MISSING
-MKDTEMP_FILES=mkdtemp.c mkdtemp.h
-else
-MKDTEMP_FILES=
-endif
-
if RUN_IN_PLACE
privdatadir = $(top_srcdir)/data/
privexecdir = $(abs_top_builddir)/src/commands/
@@ -157,7 +151,6 @@ COMMON_SOURCES = \
rar-utils.h \
typedefs.h \
ui.h \
- $(MKDTEMP_FILES) \
$(BUILT_SOURCES)
if ENABLE_JSON_GLIB