summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-04-06 10:35:15 +0200
committerraveit65 <[email protected]>2016-04-06 10:35:15 +0200
commitb260a997d9d721186bf8da641f9d624a3b0ecfb2 (patch)
treea7f7a63d0805e64fff8bf92a7893f0d5c2614e96 /Makefile.am
parent08633f380793e28f2821d36037a853faddaf5877 (diff)
downloadeom-b260a997d9d721186bf8da641f9d624a3b0ecfb2.tar.bz2
eom-b260a997d9d721186bf8da641f9d624a3b0ecfb2.tar.xz
Fix Changelog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 10 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 444cd4b..8f4066c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,22 +41,17 @@ MAINTAINERCLEANFILES = \
$(srcdir)/omf.make \
$(srcdir)/xmldocs.make
--include $(top_srcdir)/git.mk
-
# This is the last commit before the ChangeLog was converted
CHANGELOG_START = 6a7944721e667a5c2d87e841917d850aea885019
-dist-hook:
- @if test -d "$(srcdir)/.git"; \
- then \
- echo Creating ChangeLog && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log -M -C --stat \
- $(CHANGELOG_START)..) > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
- || ( rm -f ChangeLog.tmp ; \
- echo Failed to generate ChangeLog >&2 ); \
- else \
- echo A git clone is required to generate a ChangeLog >&2; \
+# Build ChangeLog from GIT history
+ChangeLog:
+ $(AM_V_GEN) if test -d $(top_srcdir)/.git; then \
+ GIT_DIR="$(top_srcdir)/.git" git log --stat > $@; \
fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
+-include $(top_srcdir)/git.mk