summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-06-23 14:38:19 +0200
committerinfirit <[email protected]>2014-06-23 14:38:19 +0200
commitfa3c5f8e647c89a268d18fe17c53797a7bc2ecc6 (patch)
tree2da5c3ce8d678104b6809170ff361d9df73f6b20 /configure.ac
parenta9876d22c237632fa0fa028698c06903e55eb6e2 (diff)
downloadeom-fa3c5f8e647c89a268d18fe17c53797a7bc2ecc6.tar.bz2
eom-fa3c5f8e647c89a268d18fe17c53797a7bc2ecc6.tar.xz
Add warning when librsvg is not found/used and add it to she summary
Make it more clear for packagers that scaling will not work for svg files. See https://github.com/mate-desktop/eom/issues/52
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa2a0fb..0200ece 100644
--- a/configure.ac
+++ b/configure.ac
@@ -313,6 +313,8 @@ fi
if test "x$have_rsvg" = "xyes"; then
AC_DEFINE(HAVE_RSVG, 1, [RSVG Support.])
EOM_MODULES="$EOM_MODULES librsvg-2.0 >= $LIBRSVG_REQUIRED"
+else
+ AC_WARN([LIBRSVG support disabled, svg files will not scale])
fi
AM_CONDITIONAL([HAVE_RSVG], [test "x$have_rsvg" = "xyes"])
@@ -517,6 +519,7 @@ Configure summary:
EXIF support ...............: ${have_exif}
XMP support ................: ${have_exempi}
JPEG support ...............: ${have_jpeg}
+ RSVG support ...............: ${have_rsvg}
Colour management support ..: ${have_lcms}
D-Bus activation............: ${have_dbus}
"