summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWolfgang Ulbrich <[email protected]>2013-09-16 13:31:49 +0200
committerWolfgang Ulbrich <[email protected]>2013-09-16 13:31:49 +0200
commite97cadd0cc567266421c8225b0fb8cd98f0da82a (patch)
tree8355dd390bc099e937badb749304d38a9917aab3 /configure.ac
parenta9448ccd8ab4c92f806710554eb3965f884960a4 (diff)
downloadeom-e97cadd0cc567266421c8225b0fb8cd98f0da82a.tar.bz2
eom-e97cadd0cc567266421c8225b0fb8cd98f0da82a.tar.xz
correct python libdir to avoid configure warnings for x86_64
DEBUG: checking whether Python support is requested... autodetect DEBUG: checking for a Python interpreter with version >= 2.3... python DEBUG: checking for python... /usr/bin/python DEBUG: checking for python version... 2.7 DEBUG: checking for python platform... linux2 DEBUG: checking for python script directory... ${prefix}/lib/python2.7/site-packages DEBUG: checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages DEBUG: sed: can't read /usr/lib/python2.7/config/Makefile: No such file or directory DEBUG: sed: can't read /usr/lib/python2.7/config/Makefile: No such file or directory DEBUG: checking for PYGTK... yes DEBUG: checking for pygobject defs... /usr/share/pygobject/2.0/defs DEBUG: checking for pygtk defs... /usr/share/pygtk/2.0/defs DEBUG: checking for pygobject codegen... /usr/bin/python /usr/share/pygobject/2.0/codegen/codegen.py DEBUG: checking for pygobject h2def... /usr/bin/python /usr/share/pygobject/2.0/codegen/h2def.py
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 189f4d5..b88105a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -365,7 +365,7 @@ if test "x$have_python" != "xno"; then
PYTHON_LIBS="-lpython$PYTHON_VERSION"
PYTHON_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config"
PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION"
- PYTHON_MAKEFILE="$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config/Makefile"
+ PYTHON_MAKEFILE="$libdir/python$PYTHON_VERSION/config/Makefile"
PYTHON_BASEMODLIBS=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
PYTHON_OTHER_LIBS=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
PYTHON_EXTRA_LIBS="$PYTHON_BASEMODLIBS $PYTHON_OTHER_LIBS"