summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorClaudio Saavedra <[email protected]>2011-06-09 22:33:30 +0300
committerraveit65 <[email protected]>2018-07-08 12:19:44 +0200
commit20d704b7b4f2560ee27cc9be25359107ceb4a14b (patch)
tree202e9a1335722c7f288019972b4e4afe5ae0f98a /configure.ac
parent63a6313edf251919487047f47ad1f08228e7ba8d (diff)
downloadeom-20d704b7b4f2560ee27cc9be25359107ceb4a14b.tar.bz2
eom-20d704b7b4f2560ee27cc9be25359107ceb4a14b.tar.xz
Port EomApplication to GtkApplication
This removes the direct dependency on dbus and makes use of the GApplication/GtkApplication facilities for uniqueness and activation. Bump the glib requirement to 2.29.4, since we need G_APPLICATION_NON_UNIQUE. https://bugzilla.gnome.org/show_bug.cgi?id=622876 origin commit: https://gitlab.gnome.org/GNOME/eog/commit/3d39587 Enable TotemScreensaver unconditionally It uses GDBus instead of libdbus now. It can be enabled even if libdbus is not available as GDBus/GIO is always present. origin commit: https://gitlab.gnome.org/GNOME/eog/commit/4c32882
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index cffdc6a..82a62fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -257,30 +257,6 @@ AC_SUBST(LIBJPEG)
AM_CONDITIONAL(ENABLE_JPEG, test x$have_jpeg = xyes)
AM_CONDITIONAL(HAVE_LIBJPEG_80, test "x$have_libjpeg_80" = xyes)
-# ****************
-# D-Bus activation
-# ****************
-
-DBUS_GLIB_REQUIRED=0.71
-
-AC_ARG_WITH([dbus], AC_HELP_STRING([--without-dbus], [disable dbus based activation]))
-have_dbus=no
-if test x$with_dbus != xno; then
- PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED], have_dbus=yes, have_dbus=no)
-fi
-if test x$have_dbus = xyes; then
- AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool], [no])
-
- if test x$DBUS_BINDING_TOOL = "xno" ; then
- AC_MSG_ERROR([dbus-binding-tool executable not found in your path - should be installed with dbus glib bindings])
- fi
-
- AC_DEFINE(HAVE_DBUS, 1, [DBUS based activation.])
- EOM_MODULES="$EOM_MODULES dbus-glib-1 >= $DBUS_GLIB_REQUIRED"
-fi
-
-AM_CONDITIONAL([HAVE_DBUS], [test "x$have_dbus" = "xyes"])
-
# ************************************
# libXML2 (required for toolbareditor)
# ************************************
@@ -390,6 +366,5 @@ Configure summary:
JPEG support ...............: ${have_jpeg}
RSVG support ...............: ${have_rsvg}
Colour management support ..: ${have_lcms}
- D-Bus activation............: ${have_dbus}
GObject Introspection.......: ${have_introspection}
"