summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-11-30 21:18:35 +0300
committermonsta <[email protected]>2016-11-30 22:24:15 +0300
commit108741a82a158996883f9d1ae19c6e65226f3309 (patch)
tree7b545ec61d19aa4ce2ac8f421493c248a70baf3a /src/Makefile.am
parent52399afcd688b56aaa0750af6d3af42c26c31abe (diff)
downloadeom-108741a82a158996883f9d1ae19c6e65226f3309.tar.bz2
eom-108741a82a158996883f9d1ae19c6e65226f3309.tar.xz
port plugin system to libpeas
backported from eog with a few changes upstream commits for reference: https://git.gnome.org/browse/eog/commit/?id=1f79c321367c91c8e9063f1343a7e4ce4199c4d5 https://git.gnome.org/browse/eog/commit/?id=9afc5483b615039a580e295fe08d7b8ec524759c https://git.gnome.org/browse/eog/commit/?id=40bedbf33812e65f4a8e79691b1fadfaace94035 https://git.gnome.org/browse/eog/commit/?id=8b0acfddc52c220393770a9895b6b56cab7821fd https://git.gnome.org/browse/eog/commit/?id=95694f8b5f06b891a5e55356451ad60b53387563 https://git.gnome.org/browse/eog/commit/?id=7eeb6c8c0e55a3ad954cde4a6fed91ea7f89691c
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1a09b57..c42c0de 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,8 +33,6 @@ NOINST_H_FILES = \
eom-print-image-setup.h \
eom-print-preview.h \
eom-print.h \
- eom-module.h \
- eom-plugin-manager.h \
eom-plugin-engine.h \
eom-close-confirmation-dialog.h \
zoom.h
@@ -60,8 +58,7 @@ INST_H_FILES = \
eom-thumbnail.h \
eom-job-queue.h \
eom-clipboard-handler.h \
- eom-jobs.h \
- eom-plugin.h
+ eom-jobs.h
libeom_c_files = \
eom-application.c \
@@ -96,10 +93,7 @@ libeom_c_files = \
eom-print-image-setup.c \
eom-print-preview.c \
eom-print.c \
- eom-module.c \
eom-close-confirmation-dialog.c \
- eom-plugin.c \
- eom-plugin-manager.c \
eom-plugin-engine.c \
eom-clipboard-handler.c \
zoom.c
@@ -138,7 +132,8 @@ libeom_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\"EOM\" \
-DEOM_DATA_DIR=\""$(pkgdatadir)"\" \
-DEOM_LOCALE_DIR=\""$(datadir)/locale"\" \
- -DEOM_PLUGIN_DIR=\""$(libdir)/eom/plugins"\"
+ -DEOM_PLUGIN_DIR=\""$(libdir)/eom/plugins"\" \
+ -DLIBDIR=\""$(libdir)"\"
libeom_la_CFLAGS = \
$(EOM_CFLAGS) \