summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c5e264a..4a82b96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -345,9 +345,13 @@ AC_SUBST(EOM_LIBS)
# *******************************************************
# Check GDK rendering target
-gdk_target=`$PKG_CONFIG --variable=target gdk-${GTK_API_VERSION}`
+if test "${GTK_API_VERSION}" = "2.0" ; then
+ gdk_target_has_x11=`$PKG_CONFIG --variable=target gdk-${GTK_API_VERSION} | grep x11`
+else
+ gdk_target_has_x11=`$PKG_CONFIG --variable=targets gdk-${GTK_API_VERSION} | grep x11`
+fi
-if test "x$have_lcms" = "xyes" || test "$gdk_target" = "x11"; then
+if test "x$have_lcms" = "xyes" || test "$gdk_target_has_x11" != ""; then
PKG_CHECK_MODULES(X11, [x11], have_x11=yes, have_x11=no)
if test "x$have_x11" != "xyes"; then