summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac114
1 files changed, 0 insertions, 114 deletions
diff --git a/configure.ac b/configure.ac
index b2cc7fa..6bf5540 100644
--- a/configure.ac
+++ b/configure.ac
@@ -373,117 +373,6 @@ fi
GLIB_GSETTINGS
-# **************
-# Python Support
-# **************
-
-AC_MSG_CHECKING([whether Python support is requested])
-
-AC_ARG_ENABLE([python],
- AS_HELP_STRING([--enable-python],[Enable python support]),
- [enable_python=$enableval have_python=$enableval],
- [enable_python=autodetect have_python=yes])
-
-AC_MSG_RESULT([$enable_python])
-
-if test "x$have_python" != "xno"; then
- AM_PATH_PYTHON([2.3],[],[no])
- if test "x$PYTHON" = "x:"; then
- have_python=no
- fi
-fi
-
-if test "x$have_python" != "xno"; then
- PY_PREFIX=`$PYTHON -c 'import sys ; print sys.prefix'`
- PY_EXEC_PREFIX=`$PYTHON -c 'import sys ; print sys.exec_prefix'`
- PYTHON_LIBS="-lpython$PYTHON_VERSION -lutil"
- PYTHON_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config"
- PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION"
- PYTHON_MAKEFILE="$libdir/python$PYTHON_VERSION/config/Makefile"
- PYTHON_BASEMODLIBS=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_OTHER_LIBS=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_EXTRA_LIBS="$PYTHON_BASEMODLIBS $PYTHON_OTHER_LIBS"
- AC_SUBST([PYTHON_LIBS])
- AC_SUBST([PYTHON_LIB_LOC])
- AC_SUBST([PYTHON_CFLAGS])
- AC_SUBST([PYTHON_EXTRA_LIBS])
-fi
-
-if test "x$have_python" != "xyes"; then
- if test "x$enable_python" = "xyes"; then
- AC_MSG_ERROR([Python not found])
- elif test "x$enable_python" = "xautodetect"; then
- enable_python=no
- AC_MSG_WARN([Python not found, disabling python support])
- fi
-fi
-
-if test "x$have_python" != "xno"; then
- PYGOBJECT_REQUIRED=2.15.1
- PYGTK_REQUIRED=2.13.0
-
- PKG_CHECK_MODULES([PYGTK], [
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
- pygtk-2.0 >= $PYGTK_REQUIRED],
- [],
- [
- have_python=no
- if test "x$enable_python" = "xyes"; then
- AC_MSG_ERROR([$PYGTK_PKG_ERRORS])
- elif test "x$enable_python" = "xautodetect"; then
- enable_python=no
- AC_MSG_WARN([$PYGTK_PKG_ERRORS])
- AC_MSG_WARN([Disabling python support])
- fi
- ])
-
- AC_SUBST([PYGTK_CFLAGS])
- AC_SUBST([PYGTK_LIBS])
-fi
-
-if test "x$have_python" != "xno"; then
- AC_MSG_CHECKING([for pygobject defs])
- PYGOBJECT_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygobject-2.0`
- AC_MSG_RESULT([$PYGOBJECT_DEFSDIR])
-
- AC_MSG_CHECKING([for pygtk defs])
- PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
- AC_MSG_RESULT([$PYGTK_DEFSDIR])
-
- AC_MSG_CHECKING([for pygobject codegen])
- PYGOBJECT_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
- AC_MSG_RESULT([$PYGOBJECT_CODEGEN])
-
- AC_MSG_CHECKING([for pygobject h2def])
- PYGOBJECT_H2DEF="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/h2def.py"
- AC_MSG_RESULT([$PYGOBJECT_H2DEF])
-
- AC_SUBST([PYGOBJECT_DEFSDIR])
- AC_SUBST([PYGTK_DEFSDIR])
- AC_SUBST([PYGOBJECT_CODEGEN])
- AC_SUBST([PYGOBJECT_H2DEF])
-
- dnl Check for -fno-strict-aliasing
- FLAGS="-fno-strict-aliasing"
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $FLAGS"
- AC_MSG_CHECKING([whether [$]CC understands $FLAGS])
- AC_TRY_COMPILE([], [], [compiler_has_option=yes], [compiler_has_option=no])
- CFLAGS="$save_CFLAGS"
- AC_MSG_RESULT($compiler_has_option)
- if test $compiler_has_option = yes; then
- NO_STRICT_ALIASING_CFLAGS="$FLAGS"
- fi
- AC_SUBST([NO_STRICT_ALIASING_CFLAGS])
-fi
-
-if test "x$have_python" != "xno" -a "x$enable_python" != "xno"; then
- enable_python=yes
- AC_DEFINE([ENABLE_PYTHON],[1],[Define to compile with python support])
-fi
-
-AM_CONDITIONAL([ENABLE_PYTHON],[test "x$enable_python" = "xyes"])
-
AC_SEARCH_LIBS([floor],[m])
AC_CONFIG_FILES([
@@ -513,8 +402,6 @@ doc/reference/Makefile
doc/reference/version.xml
doc/reference/eom-docs.sgml
plugins/Makefile
-bindings/Makefile
-bindings/python/Makefile
])
AC_OUTPUT
@@ -527,7 +414,6 @@ Configure summary:
Extra Compiler Warnings ....: ${WARN_CFLAGS}
GTK version ................: ${GTK_API_VERSION}
- Python support .............: ${have_python}
EXIF support ...............: ${have_exif}
XMP support ................: ${have_exempi}
JPEG support ...............: ${have_jpeg}