summaryrefslogtreecommitdiff
path: root/libmateweather/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-10-10 13:39:28 +0200
committerStefano Karapetsas <[email protected]>2012-10-10 13:39:28 +0200
commit6fc7fa8f772083bda5cb4b4956150db5d155e060 (patch)
tree81a26ffc5ab65165534b852fff88783ea7e3ba52 /libmateweather/Makefile.am
parent47a9ffc53ceba87023e443a6ab362c52ac799635 (diff)
downloadlibmateweather-6fc7fa8f772083bda5cb4b4956150db5d155e060.tar.bz2
libmateweather-6fc7fa8f772083bda5cb4b4956150db5d155e060.tar.xz
add gettext to gschemalibmateweather-1.5.0
Diffstat (limited to 'libmateweather/Makefile.am')
-rw-r--r--libmateweather/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/libmateweather/Makefile.am b/libmateweather/Makefile.am
index 41a35fe..608f5d7 100644
--- a/libmateweather/Makefile.am
+++ b/libmateweather/Makefile.am
@@ -122,14 +122,18 @@ test_sun_moon_LDADD = \
noinst_HEADERS = weather-priv.h mateweather-win32.h
noinst_PROGRAMS = test_metar test_locations test_sun_moon
+@INTLTOOL_XML_NOMERGE_RULE@
gsettings_SCHEMAS = org.mate.weather.gschema.xml
@GSETTINGS_RULES@
-EXTRA_DIST = mateweather.pc.in mateweather-uninstalled.pc.in $(gsettings_SCHEMAS)
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
+
+EXTRA_DIST = mateweather.pc.in mateweather-uninstalled.pc.in $(gsettings_schemas_in_in)
EXTRA_PROGRAMS = test_metar test_sun_moon
-CLEANFILES = $(schema_DATA) $(EXTRA_PROGRAMS)
+CLEANFILES = $(EXTRA_PROGRAMS) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS) *.gschema.valid
#$(MKENUMS_GENERATED)
-include $(top_srcdir)/git.mk