summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 2 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 9bcb32e..81d1500 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,27 +21,8 @@ AC_SUBST(LT_VERSION)
AC_CANONICAL_HOST
-AC_MSG_CHECKING([which gtk+ version to compile against])
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk=2.0|3.0],[which gtk+ version to compile against (default: 2.0)])],
- [case "$with_gtk" in
- 2.0|3.0) ;;
- *) AC_MSG_ERROR([invalid gtk version specified]) ;;
- esac],
- [with_gtk=2.0])
-AC_MSG_RESULT([$with_gtk])
-
-case "$with_gtk" in
- 2.0) GTK_API_VERSION=2.0
- GTK_REQUIRED=2.24.0
- ;;
- 3.0) GTK_API_VERSION=3.0
- GTK_REQUIRED=3.0.0
- ;;
-esac
-AC_SUBST(GTK_API_VERSION)
-
GLIB_REQUIRED=2.36.0
+GTK_REQUIRED=3.14.0
LIBSOUP_REQUIRED=2.34.0
GIO_REQUIRED=2.25.0
LIBXML_REQUIRED=2.6.0
@@ -80,7 +61,7 @@ AC_SUBST(COMPRESS_EXT)
MATE_COMPILE_WARNINGS([maximum])
dnl -- Check for GTK+ (required) ------------------------------------------
-PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED)
+PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)
dnl -- Check for libxml (required) ------------------------------------------
PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED)
@@ -216,5 +197,4 @@ libmateweather-$VERSION configure summary:
Compiler: ${CC}
Locations.xml translations: ${LOCATIONS_XML_TRANSLATIONS}
Locations.xml compression: ${enable_locations_compression}
- Gtk+ version: ${GTK_API_VERSION}
" >&2