summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index ce1b8fc..6cdf18c 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -53,10 +53,6 @@ $(LOCATIONS_STAMP): $(libmateweatherlocations_in_files) $(PO_LOCATIONS) Makefile
endif # USE_ONE_BIG_XML
-check:
- xmllint --valid --noout $(top_srcdir)/data/Locations.xml.in
- $(srcdir)/check-timezones.sh $(srcdir)/Locations.xml.in
-
### Locations.xml.in rebuild
rebuild-locations: locationdb.sqlite update-locations.py
$(AM_V_GEN)($(srcdir)/update-locations.py > Locations.xml.in.new && mv Locations.xml.in.new Locations.xml.in) || rm -f Locations.xml.in.new
@@ -64,6 +60,10 @@ rebuild-locations: locationdb.sqlite update-locations.py
locationdb.sqlite: build-locationdb.pl major-cities.txt sources/nsd_cccc.txt sources/POP_PLACES.txt sources/US_CONCISE.txt sources/geonames_dd_dms_date_*.txt city-fixups.pl station-fixups.pl
$(AM_V_GEN)$(srcdir)/build-locationdb.pl
+check:
+ xmllint --valid --noout $(top_srcdir)/data/Locations.xml.in
+ $(srcdir)/check-timezones.sh $(srcdir)/Locations.xml.in
+
EXTRA_DIST = \
$(libmateweatherlocations_in_files) \
$(libmateweatherdtd_DATA) \