summaryrefslogtreecommitdiff
path: root/libmateweather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmateweather/Makefile.am')
-rw-r--r--libmateweather/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/libmateweather/Makefile.am b/libmateweather/Makefile.am
index 41a35fe..608f5d7 100644
--- a/libmateweather/Makefile.am
+++ b/libmateweather/Makefile.am
@@ -122,14 +122,18 @@ test_sun_moon_LDADD = \
noinst_HEADERS = weather-priv.h mateweather-win32.h
noinst_PROGRAMS = test_metar test_locations test_sun_moon
+@INTLTOOL_XML_NOMERGE_RULE@
gsettings_SCHEMAS = org.mate.weather.gschema.xml
@GSETTINGS_RULES@
-EXTRA_DIST = mateweather.pc.in mateweather-uninstalled.pc.in $(gsettings_SCHEMAS)
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
+
+EXTRA_DIST = mateweather.pc.in mateweather-uninstalled.pc.in $(gsettings_schemas_in_in)
EXTRA_PROGRAMS = test_metar test_sun_moon
-CLEANFILES = $(schema_DATA) $(EXTRA_PROGRAMS)
+CLEANFILES = $(EXTRA_PROGRAMS) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS) *.gschema.valid
#$(MKENUMS_GENERATED)
-include $(top_srcdir)/git.mk