summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-16 21:57:06 -0300
committerPerberos <[email protected]>2011-11-16 21:57:06 -0300
commitcd07243ada482a69a238bb54851a002900b2816e (patch)
tree69eb126fd91a61e6a09cc429bcbcf2d91e563a58 /Makefile.am
parent413fd17ad0764b9a76bff87f91ae355504e4e95f (diff)
downloadmate-applets-cd07243ada482a69a238bb54851a002900b2816e.tar.bz2
mate-applets-cd07243ada482a69a238bb54851a002900b2816e.tar.xz
removing deleted folders
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am103
1 files changed, 52 insertions, 51 deletions
diff --git a/Makefile.am b/Makefile.am
index b0e64792..b9c35b43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,17 +1,20 @@
gtop_applets = multiload
+
if BUILD_GTOP_APPLETS
gtop_SUBDIRS = $(gtop_applets)
endif
libmateweather_applets = \
mateweather
+
if BUILD_LIBMATEWEATHER_APPLETS
libmateweather_SUBDIRS = $(libmateweather_applets)
endif
modemlights_applets = \
modemlights
+
if APPLET_MODEMLIGHTS
modemlights_SUBDIRS = $(modemlights_applets)
endif
@@ -36,64 +39,61 @@ if BUILD_MIXER_APPLET
mixer_applet_SUBDIR = mixer
endif
-always_built_SUBDIRS = \
- charpick \
- drivemount \
- geyes \
- mini-commander \
- gkb-new \
- stickynotes \
- trashapplet \
+always_built_SUBDIRS = \
+ charpick \
+ drivemount \
+ geyes \
+ mini-commander \
+ stickynotes \
+ trashapplet \
null_applet
SUBDIRS = \
- po \
- $(always_built_SUBDIRS) \
- $(modemlights_SUBDIRS) \
- $(gtop_SUBDIRS) \
- $(libmateweather_SUBDIRS) \
- $(vfs_SUBDIRS) \
- $(battstat_SUBDIR) \
- $(accessx_status_SUBDIR)\
- $(invest_applet_SUBDIR) \
+ po \
+ $(always_built_SUBDIRS) \
+ $(modemlights_SUBDIRS) \
+ $(gtop_SUBDIRS) \
+ $(libmateweather_SUBDIRS) \
+ $(vfs_SUBDIRS) \
+ $(battstat_SUBDIR) \
+ $(accessx_status_SUBDIR) \
+ $(invest_applet_SUBDIR) \
$(cpufreq_SUBDIR) \
$(mixer_applet_SUBDIR)
DIST_SUBDIRS = \
- po \
- modemlights \
- drivemount \
- charpick \
- geyes \
- mini-commander \
- gkb-new \
- battstat \
- multiload \
- mateweather \
- man \
- accessx-status \
- stickynotes \
- gswitchit \
- trashapplet \
- cpufreq \
- invest-applet \
- mixer \
+ po \
+ modemlights \
+ drivemount \
+ charpick \
+ geyes \
+ mini-commander \
+ battstat \
+ multiload \
+ mateweather \
+ man \
+ accessx-status \
+ stickynotes \
+ trashapplet \
+ cpufreq \
+ invest-applet \
+ mixer \
null_applet
EXTRA_DIST = \
- MAINTAINERS \
- m4/ac-define-dir.m4 \
- COPYING-DOCS \
- mate-applets.spec.in \
- mate-applets.spec \
- intltool-update.in \
- intltool-extract.in \
- intltool-merge.in \
- xmldocs.make \
- omf.make \
+ MAINTAINERS \
+ m4/ac-define-dir.m4 \
+ COPYING-DOCS \
+ mate-applets.spec.in \
+ mate-applets.spec \
+ intltool-update.in \
+ intltool-extract.in \
+ intltool-merge.in \
+ xmldocs.make \
+ omf.make \
mate-doc-utils.make
-DISTCHECK_CONFIGURE_FLAGS = \
+DISTCHECK_CONFIGURE_FLAGS = \
--disable-scrollkeeper \
--enable-mini-commander \
--enable-mixer-applet
@@ -111,14 +111,15 @@ dist: ChangeLog
# hack from sound-juicer to get around scrollkeeper's leaving a big
# mess behind.
-distuninstallcheck_listfiles = \
+distuninstallcheck_listfiles = \
find -regex '.*/var/scrollkeeper/.*' -prune -or -type f -print
ACLOCAL_AMFLAGS = -I m4
-DISTCLEANFILES = intltool-extract \
- intltool-merge \
- intltool-update \
- mate-doc-utils.make
+DISTCLEANFILES = intltool-extract \
+ intltool-merge \
+ intltool-update \
+ mate-doc-utils.make
-include $(top_srcdir)/git.mk
+