summaryrefslogtreecommitdiff
path: root/battstat/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-06 21:55:35 +0200
committerinfirit <[email protected]>2015-09-06 21:55:35 +0200
commitdf7a7488950139e3884972e2363294051e33d45d (patch)
treec442d94aba98b29a69a743701bf9a7d7a1086950 /battstat/Makefile.am
parent6bfc67fc80ba929a740d20edd9ba34927dfefafe (diff)
downloadmate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.bz2
mate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'battstat/Makefile.am')
-rw-r--r--battstat/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/battstat/Makefile.am b/battstat/Makefile.am
index 642a128f..648e0789 100644
--- a/battstat/Makefile.am
+++ b/battstat/Makefile.am
@@ -60,12 +60,10 @@ battstat_applet_LDADD = \
-lm
@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = org.mate.panel.applet.battstat.gschema.xml
+batstat_gschema_in_files = org.mate.panel.applet.battstat.gschema.xml.in
+gsettings_SCHEMAS = $(batstat_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.BattstatApplet.mate-panel-applet.in
applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
@@ -87,7 +85,7 @@ org.mate.panel.applet.BattstatAppletFactory.service: $(service_in_files)
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
uidir = $(datadir)/mate/ui
ui_DATA = battstat-applet-menu.xml
@@ -97,7 +95,7 @@ EXTRA_DIST = \
$(ui_DATA) \
org.mate.applets.BattstatApplet.mate-panel-applet.in.in \
$(service_in_files) \
- $(gsettings_SCHEMAS).in.in
+ $(batstat_gschema_in_files)
-include $(top_srcdir)/git.mk