summaryrefslogtreecommitdiff
path: root/command/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-06 21:55:35 +0200
committerinfirit <[email protected]>2015-09-06 21:55:35 +0200
commitdf7a7488950139e3884972e2363294051e33d45d (patch)
treec442d94aba98b29a69a743701bf9a7d7a1086950 /command/Makefile.am
parent6bfc67fc80ba929a740d20edd9ba34927dfefafe (diff)
downloadmate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.bz2
mate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'command/Makefile.am')
-rw-r--r--command/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/command/Makefile.am b/command/Makefile.am
index e9df3c81..3159add3 100644
--- a/command/Makefile.am
+++ b/command/Makefile.am
@@ -32,15 +32,13 @@ org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
$< > $@
@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = org.mate.panel.applet.command.gschema.xml
+command_gschema_in_files = org.mate.panel.applet.command.gschema.xml.in
+gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
EXTRA_DIST = \
$(applets_in_files).in \
$(service_in_files) \
- $(gsettings_SCHEMAS).in.in
+ $(command_gschema_in_files)
-CLEANFILES = $(applets_DATA) $(applets_DATA).in $(service_DATA) $(gsettings_SCHEMAS_in) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = $(applets_DATA) $(applets_DATA).in $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid