summaryrefslogtreecommitdiff
path: root/cpufreq/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-14 18:24:48 -0300
committerPerberos <[email protected]>2011-11-14 18:24:48 -0300
commit312ba610a1e98fc656fb58178227d7d45a64494e (patch)
tree54a3c2b6084c80e63fb0526c6e7b8e01627acbd7 /cpufreq/Makefile.am
downloadmate-applets-312ba610a1e98fc656fb58178227d7d45a64494e.tar.bz2
mate-applets-312ba610a1e98fc656fb58178227d7d45a64494e.tar.xz
initial
Diffstat (limited to 'cpufreq/Makefile.am')
-rw-r--r--cpufreq/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/cpufreq/Makefile.am b/cpufreq/Makefile.am
new file mode 100644
index 00000000..f2b4f80e
--- /dev/null
+++ b/cpufreq/Makefile.am
@@ -0,0 +1,58 @@
+SUBDIRS = help pixmaps src
+
+schemasdir = @MATECONF_SCHEMA_FILE_DIR@
+schemas_in_files = cpufreq-applet.schemas.in
+schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
+
+@INTLTOOL_SCHEMAS_RULE@
+
+appletdir = $(datadir)/mate-panel/applets
+applet_in_files = org.mate.applets.CPUFreqApplet.mate-panel-applet.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+
+$(applet_in_files): $(applet_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
+
+%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.CPUFreqAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.CPUFreqAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $< > $@
+
+builder_DATA = cpufreq-preferences.ui
+
+uidir = $(datadir)/mate-2.0/ui
+ui_DATA = cpufreq-applet-menu.xml
+
+if MATECONF_SCHEMAS_INSTALL
+install-data-local:
+ -MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(top_builddir)/cpufreq/$(schemas_DATA) ;
+endif
+
+CLEANFILES = \
+ $(applet_DATA) \
+ $(applet_DATA).in \
+ $(service_DATA) \
+ cpufreq-applet.schemas \
+ *.bak \
+ *.gladep
+
+EXTRA_DIST = \
+ org.mate.applets.CPUFreqApplet.mate-panel-applet.in.in \
+ $(service_in_files) \
+ $(schemas_in_files) \
+ $(builder_DATA) \
+ $(ui_DATA)
+
+
+
+
+-include $(top_srcdir)/git.mk