summaryrefslogtreecommitdiff
path: root/cpufreq/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-11-28 20:26:22 +0100
committerraveit65 <[email protected]>2020-12-09 21:16:36 +0100
commit4cb6f915b1a91497df1b13cdab887df1bdaed101 (patch)
treeef32f9e4d6f6f75de2e15da5bff69562ac7581dc /cpufreq/src/Makefile.am
parent66b18c097d5ae6e7bcf712820bc3e6594c8cb79a (diff)
downloadmate-applets-4cb6f915b1a91497df1b13cdab887df1bdaed101.tar.bz2
mate-applets-4cb6f915b1a91497df1b13cdab887df1bdaed101.tar.xz
cpufreq: Remove /proc/cpufreq support (Linux 2.4)
Diffstat (limited to 'cpufreq/src/Makefile.am')
-rw-r--r--cpufreq/src/Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/cpufreq/src/Makefile.am b/cpufreq/src/Makefile.am
index cd64db9e..e7b42722 100644
--- a/cpufreq/src/Makefile.am
+++ b/cpufreq/src/Makefile.am
@@ -10,10 +10,6 @@ AM_CPPFLAGS = \
libexec_PROGRAMS = mate-cpufreq-applet
-if HAVE_LIBCPUFREQ
-cpufreq_files=cpufreq-monitor-libcpufreq.c cpufreq-monitor-libcpufreq.h
-endif
-
BUILT_SOURCES = \
cpufreq-resources.c cpufreq-resources.h
@@ -27,11 +23,19 @@ mate_cpufreq_applet_SOURCES = \
cpufreq-selector.c cpufreq-selector.h \
cpufreq-popup.c cpufreq-popup.h \
cpufreq-monitor.c cpufreq-monitor.h \
- cpufreq-monitor-factory.c cpufreq-monitor-factory.h \
- cpufreq-monitor-procfs.c cpufreq-monitor-procfs.h \
- cpufreq-monitor-sysfs.c cpufreq-monitor-sysfs.h \
- $(cpufreq_files) \
- cpufreq-monitor-cpuinfo.c cpufreq-monitor-cpuinfo.h
+ cpufreq-monitor-factory.c cpufreq-monitor-factory.h
+
+if HAVE_LIBCPUFREQ
+mate_cpufreq_applet_SOURCES += \
+ cpufreq-monitor-libcpufreq.c \
+ cpufreq-monitor-libcpufreq.h
+else
+mate_cpufreq_applet_SOURCES += \
+ cpufreq-monitor-cpuinfo.c \
+ cpufreq-monitor-cpuinfo.h \
+ cpufreq-monitor-sysfs.c \
+ cpufreq-monitor-sysfs.h
+endif
mate_cpufreq_applet_CFLAGS = \
${WARN_CFLAGS}