summaryrefslogtreecommitdiff
path: root/cpufreq/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-04-16 11:32:25 +0200
committerraveit65 <[email protected]>2020-05-21 20:22:59 +0200
commitc05e8a98283929fd7cd97889a96756b57ee79839 (patch)
tree3e865bb70dc37a4d6bf91e1ba97c0e8ed1b5236a /cpufreq/src/Makefile.am
parent47928c3969e56bbfed6755a79096e48e61c36454 (diff)
downloadmate-applets-c05e8a98283929fd7cd97889a96756b57ee79839.tar.bz2
mate-applets-c05e8a98283929fd7cd97889a96756b57ee79839.tar.xz
build: Use dbus-glib only when required
Diffstat (limited to 'cpufreq/src/Makefile.am')
-rw-r--r--cpufreq/src/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/cpufreq/src/Makefile.am b/cpufreq/src/Makefile.am
index b9a3781c..bfa6fd48 100644
--- a/cpufreq/src/Makefile.am
+++ b/cpufreq/src/Makefile.am
@@ -6,9 +6,12 @@ SUBDIRS = $(selector_SUBDIR)
AM_CPPFLAGS = \
-DCPUFREQ_MENU_UI_DIR=\""$(datadir)/mate/ui"\" \
- $(MATE_APPLETS4_CFLAGS) \
- $(MATEDESKTOP_CFLAGS) \
- $(DBUS_CFLAGS)
+ $(MATE_APPLETS4_CFLAGS) \
+ $(MATEDESKTOP_CFLAGS)
+
+if HAVE_DBUS
+AM_CPPFLAGS += $(DBUS_CFLAGS)
+endif
libexec_PROGRAMS = mate-cpufreq-applet
@@ -35,7 +38,10 @@ mate_cpufreq_applet_CFLAGS = \
mate_cpufreq_applet_LDADD = \
$(MATE_APPLETS4_LIBS) \
$(MATEDESKTOP_LIBS) \
- $(LIBCPUFREQ_LIBS) \
- $(DBUS_LIBS)
+ $(LIBCPUFREQ_LIBS)
+
+if HAVE_DBUS
+mate_cpufreq_applet_LDADD += $(DBUS_LIBS)
+endif
-include $(top_srcdir)/git.mk