summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 36 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index ef62a368..de5ec7d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl ***************************************************************************
dnl *** configure.in for MATE-APPLETS ***
dnl ***************************************************************************
-AC_INIT([mate-applets], [1.26.0], [https://github.com/mate-desktop/mate-applets/issues],
+AC_INIT([mate-applets], [1.28.0], [https://github.com/mate-desktop/mate-applets/issues],
[mate-applets], [https://mate-desktop.org])
AC_PREREQ(2.59)
@@ -25,6 +25,7 @@ LIBXML_REQUIRED=2.5.0
POLKIT_REQUIRED=0.97
LIBWNCK_REQUIRED=3.0.0
GUCHARMAP_REQUIRED=3.0.0
+MATE_DESKTOP_REQUIRED=1.27.1
dnl ***************************************************************************
AM_MAINTAINER_MODE
@@ -63,6 +64,11 @@ PKG_CHECK_MODULES(MATE_APPLETS4, libmatepanelapplet-4.0 >= $LIBPANEL4_REQUIRED)
AC_SUBST(MATE_APPLETS4_CFLAGS)
AC_SUBST(MATE_APPLETS4_LIBS)
+dnl -- check for mate-desktop-2.0 (required) ------------------------------------
+PKG_CHECK_MODULES(MATE_DESKTOP, mate-desktop-2.0 >= $MATE_DESKTOP_REQUIRED)
+AC_SUBST(MATE_DESKTOP_CFLAGS)
+AC_SUBST(MATE_DESKTOP_LIBS)
+
dnl -- check for libgtop (optional) -------------------------------------------
build_gtop_applets=false
PKG_CHECK_MODULES(GTOP_APPLETS,
@@ -95,7 +101,7 @@ AC_SUBST(LIBNOTIFY_LIBS)
dnl -- Check for D-Bus -----------------------------------------
AC_ARG_WITH(dbus-sys,
- [AC_HELP_STRING([--with-dbus-sys=<dir>],
+ [AS_HELP_STRING([--with-dbus-sys=<dir>],
[where D-BUS system.d directory is])])
if ! test -z "$with_dbus_sys" ; then
DBUS_SYS_DIR="$with_dbus_sys"
@@ -119,7 +125,7 @@ dnl -- check for PolicyKit and PolicyKit-mate (optional) -----------------------
POLKIT_CFLAGS=
POLKIT_LIBS=
AC_ARG_ENABLE([polkit],
- AC_HELP_STRING([--enable-polkit], [Enable PolicyKit support @<:@default yes@:>@]),
+ AS_HELP_STRING([--enable-polkit], [Enable PolicyKit support @<:@default yes@:>@]),
enable_polkit=$enableval,
enable_polkit=yes)
if test "x$enable_polkit" != "xno"; then
@@ -249,10 +255,6 @@ if test x$disable_battstat = xno; then
build_battstat_applet=yes
AC_CHECK_HEADERS([err.h sys/sysctl.h])
case "${host}" in
- powerpc-*-linux*)
- NEED_LIBAPM=yes
- AC_CHECK_LIB(apm,apm_read,[HAVE_LIBAPM=yes],[HAVE_LIBAPM=no])
- ;;
# list of supported OS cores that use libapm
*-*-linux*)
NEED_LIBAPM=yes
@@ -292,11 +294,11 @@ dnl ***************************************************************************
dnl *** Stickynotes specific checks ***
dnl ***************************************************************************
AC_ARG_ENABLE([stickynotes],
- AC_HELP_STRING([--enable-stickynotes], [Enable stickynotes applet.]),
+ AS_HELP_STRING([--enable-stickynotes], [Enable stickynotes applet.]),
enable_stickynotes=$enableval,
enable_stickynotes=yes)
if test "x$enable_stickynotes" = "xyes"; then
- PKG_CHECK_MODULES(STICKYNOTES, gtksourceview-3.0,
+ PKG_CHECK_MODULES(STICKYNOTES, gtksourceview-4,
have_gtksourceview=yes, have_gtksourceview=no)
if test "x$enable_stickynotes" = "xyes" -a "x$have_gtksourceview" = "xno"; then
@@ -516,6 +518,27 @@ if test "$gtk_ok" = "yes"; then
[Define if _NL_MEASUREMENT_MEASUREMENT is available])
fi
+AC_ARG_ENABLE([in-process],
+ [AS_HELP_STRING([--enable-in-process],
+ [Build all applets in-process])],
+ [enable_in_process=$enableval],
+ [enable_in_process=no])
+
+# Automake conditional on whether to build in-process
+AM_CONDITIONAL([ENABLE_IN_PROCESS], [test "x$enable_in_process" = "xyes"])
+# Automake value expected to be substitued in .mate-panel-apple.* for the value of "InProcess"
+AS_IF([test "x$enable_in_process" = "xyes"],
+ [AC_SUBST([APPLET_IN_PROCESS], [true])],
+ [AC_SUBST([APPLET_IN_PROCESS], [false])])
+# C conditional on whether to build in-process
+AS_IF([test "x$enable_in_process" = "xyes"],
+ [AC_DEFINE([ENABLE_IN_PROCESS], [1], [building in-process])])
+# Convenience C define selecting the right applet factory
+AS_IF([test "x$enable_in_process" = "xyes"],
+ [factory=MATE_PANEL_APPLET_IN_PROCESS_FACTORY],
+ [factory=MATE_PANEL_APPLET_OUT_PROCESS_FACTORY])
+AC_DEFINE_UNQUOTED([PANEL_APPLET_FACTORY], [$factory], [Panel applet factory])
+
dnl ***************************************************************************
dnl *** Honour aclocal flags ***
dnl ***************************************************************************
@@ -594,11 +617,13 @@ stickynotes/org.mate.stickynotes.gschema.xml
stickynotes/pixmaps/Makefile
stickynotes/docs/Makefile
trashapplet/Makefile
+trashapplet/data/Makefile
trashapplet/src/Makefile
trashapplet/docs/Makefile
cpufreq/Makefile
+cpufreq/data/Makefile
+cpufreq/data/org.mate.panel.applet.cpufreq.gschema.xml
cpufreq/src/Makefile
-cpufreq/org.mate.panel.applet.cpufreq.gschema.xml
cpufreq/src/cpufreq-selector/Makefile
cpufreq/pixmaps/Makefile
cpufreq/help/Makefile
@@ -658,4 +683,5 @@ Configure summary:
Using UPOWER: $HAVE_UPOWER
Using libnotify: $HAVE_LIBNOTIFY
Enabling IPv6: $have_ipv6
+ Build in-process: $enable_in_process
" >&2