summaryrefslogtreecommitdiff
path: root/geyes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'geyes/Makefile.am')
-rw-r--r--geyes/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/geyes/Makefile.am b/geyes/Makefile.am
index f8bb8c28..38921e31 100644
--- a/geyes/Makefile.am
+++ b/geyes/Makefile.am
@@ -22,8 +22,8 @@ mate_geyes_applet_LDADD = \
-lm
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.GeyesApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.applets.GeyesApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -31,7 +31,8 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.GeyesAppletFactory.service.in
@@ -45,7 +46,6 @@ org.mate.panel.applet.GeyesAppletFactory.service: $(service_in_files)
uidir = $(datadir)/mate/ui
ui_DATA = geyes-applet-menu.xml
-@INTLTOOL_XML_NOMERGE_RULE@
geyes_gschema_in_files = org.mate.panel.applet.geyes.gschema.xml.in
gsettings_SCHEMAS = $(geyes_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
@@ -59,12 +59,12 @@ icons = \
mate-eyes-applet.22.png \
mate-eyes-applet.16.png
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
EXTRA_DIST = \
README.themes \
- org.mate.applets.GeyesApplet.mate-panel-applet.in.in \
- $(service_in_files) \
+ $(applet_in_files).in \
+ $(service_in_files) \
$(geyes_gschema_in_files) \
$(ui_DATA) \
$(icons)