summaryrefslogtreecommitdiff
path: root/mateweather/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/Makefile.am')
-rw-r--r--mateweather/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/mateweather/Makefile.am b/mateweather/Makefile.am
index c8ec98e5..37ce65ce 100644
--- a/mateweather/Makefile.am
+++ b/mateweather/Makefile.am
@@ -34,8 +34,8 @@ uidir = $(datadir)/mate/ui
ui_DATA = mateweather-applet-menu.xml
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -43,7 +43,8 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.MateWeatherAppletFactory.service.in
@@ -54,10 +55,10 @@ org.mate.panel.applet.MateWeatherAppletFactory.service: $(service_in_files)
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA)
+CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA)
EXTRA_DIST = \
- org.mate.applets.MateWeatherApplet.mate-panel-applet.in.in \
+ $(applet_in_files).in \
$(service_in_files) \
$(ui_DATA)