summaryrefslogtreecommitdiff
path: root/netspeed/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netspeed/data/Makefile.am')
-rw-r--r--netspeed/data/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/netspeed/data/Makefile.am b/netspeed/data/Makefile.am
index 5bc783cf..7875af7d 100644
--- a/netspeed/data/Makefile.am
+++ b/netspeed/data/Makefile.am
@@ -1,14 +1,16 @@
APPLET_LOCATION = $(libexecdir)/mate-netspeed-applet
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.NetspeedApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.applets.NetspeedApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
xmluidir = $(datadir)/mate/ui
xmlui_DATA = netspeed-menu.xml
@@ -24,11 +26,10 @@ org.mate.panel.applet.NetspeedAppletFactory.service: $(service_in_files)
netspeed_gschema_in_files = org.mate.panel.applet.netspeed.gschema.xml.in
gsettings_SCHEMAS = $(netspeed_gschema_in_files:.xml.in=.xml)
-@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
EXTRA_DIST = \
- org.mate.applets.NetspeedApplet.mate-panel-applet.in.in \
+ $(applet_in_files).in \
$(xmlui_DATA) \
$(service_in_files) \
$(netspeed_gschema_in_files)
@@ -37,7 +38,7 @@ CLEANFILES = \
$(gsettings_SCHEMAS) \
$(service_DATA) \
$(applet_in_files) \
- org.mate.applets.NetspeedApplet.mate-panel-applet
+ $(applet_DATA)
-include $(top_srcdir)/git.mk