summaryrefslogtreecommitdiff
path: root/stickynotes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'stickynotes/Makefile.am')
-rw-r--r--stickynotes/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/stickynotes/Makefile.am b/stickynotes/Makefile.am
index 8ab9f7d0..04e79144 100644
--- a/stickynotes/Makefile.am
+++ b/stickynotes/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = pixmaps docs
ui_files = stickynotes-applet-menu.xml
builder_files = stickynotes.ui
-applet_in_files = org.mate.applets.StickyNotesApplet.mate-panel-applet.in
+applet_in_files = org.mate.applets.StickyNotesApplet.mate-panel-applet.desktop.in
service_in_files = org.mate.panel.applet.StickyNotesAppletFactory.service.in
schemas_in_files = stickynotes.schemas.in
@@ -46,13 +46,12 @@ builder_DATA = $(builder_files)
uidir = $(datadir)/mate/ui
ui_DATA = $(ui_files)
-@INTLTOOL_XML_NOMERGE_RULE@
stickynotes_gschema_in_files = org.mate.stickynotes.gschema.xml.in
gsettings_SCHEMAS = $(stickynotes_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
appletdir = $(datadir)/mate-panel/applets
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -60,7 +59,8 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_DATA = $(service_in_files:.service.in=.service)
@@ -70,7 +70,7 @@ org.mate.panel.applet.StickyNotesAppletFactory.service: $(service_in_files)
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
endif
@@ -79,7 +79,7 @@ EXTRA_DIST = \
$(ui_files) \
$(stickynotes_gschema_in_files) \
$(service_in_files) \
- org.mate.applets.StickyNotesApplet.mate-panel-applet.in.in
+ $(applet_in_files).in
-include $(top_srcdir)/git.mk