summaryrefslogtreecommitdiff
path: root/trashapplet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trashapplet/Makefile.am')
-rw-r--r--trashapplet/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/trashapplet/Makefile.am b/trashapplet/Makefile.am
index 27160254..7941dba2 100644
--- a/trashapplet/Makefile.am
+++ b/trashapplet/Makefile.am
@@ -1,8 +1,8 @@
SUBDIRS = src docs
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.TrashApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.applets.TrashApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
@@ -10,7 +10,8 @@ $(applet_in_files): $(applet_in_files).in Makefile
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.TrashAppletFactory.service.in
@@ -28,10 +29,10 @@ builder_DATA = trashapplet-empty-progress.ui
EXTRA_DIST = \
$(ui_DATA) \
- org.mate.applets.TrashApplet.mate-panel-applet.in.in \
+ $(applet_in_files).in \
$(service_in_files) \
$(builder_DATA)
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA)
+CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA)
-include $(top_srcdir)/git.mk