summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-30 18:59:39 -0300
committerPerberos <[email protected]>2011-11-30 18:59:39 -0300
commite59145232c55785c2d5687d615016e6250140e79 (patch)
treefc459bc643fa6f0c7ee37a234370bff28e08b200 /Makefile.am
downloadmate-backgrounds-e59145232c55785c2d5687d615016e6250140e79.tar.bz2
mate-backgrounds-e59145232c55785c2d5687d615016e6250140e79.tar.xz
moving from https://github.com/perberos/Mate-Desktop-Environment
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9b62b69
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,42 @@
+SUBDIRS = abstract nature po
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat -M -C \
+ --name-status --date=short MATE_BACKGROUNDS_2_30_0.. ) \
+ > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2; exit 1 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi
+
+
+EXTRA_DIST = \
+ MAINTAINERS
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ aclocal.m4 \
+ config.h.in \
+ configure \
+ depcomp \
+ install-sh \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
+ missing \
+ mkinstalldirs
+
+
+-include $(top_srcdir)/git.mk