summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 616f28c..5e1b579 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.62)
-AC_INIT([mate-calc], [1.25.0], [http://mate-desktop.org])
+AC_INIT([mate-calc], [1.28.0], [https://github.com/mate-desktop/mate-calc/issues],
+ [mate-calc], [https://mate-desktop.org])
AM_INIT_AUTOMAKE([1.9 foreign no-dist-gzip dist-xz check-news])
AC_CONFIG_HEADERS(config.h)
@@ -44,7 +45,7 @@ GLIB_MKENUMS=`$PKG_CONFIG --variable=glib_mkenums glib-2.0`
AC_SUBST(GLIB_MKENUMS)
AC_CHECK_LIB(m, log)
-AC_CHECK_LIB(mpc, log)
+AC_CHECK_LIB(mpc, log, [], [AC_MSG_ERROR(could not find required development libraries for MPC)], [])
dnl ###########################################################################
dnl Internationalization
@@ -52,7 +53,10 @@ dnl ###########################################################################
AM_GNU_GETTEXT_VERSION([0.19.8])
AM_GNU_GETTEXT_REQUIRE_VERSION([0.19.8])
AM_GNU_GETTEXT([external])
-AC_SUBST(GETTEXT_PACKAGE, mate-calc)
+
+GETTEXT_PACKAGE=AC_PACKAGE_NAME
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[the gettext translation domain])
# **********************
# GLIB_COMPILE_RESOURCES
@@ -82,10 +86,24 @@ dnl ###########################################################################
dnl Files to generate
dnl ###########################################################################
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
src/Makefile
po/Makefile.in
data/Makefile
help/Makefile
])
+AC_OUTPUT
+
+echo "
+Configure summary:
+
+ ${PACKAGE_STRING}
+ `echo $PACKAGE_STRING | sed "s/./=/g"`
+
+ prefix: ${prefix}
+ source code location: ${srcdir}
+ compiler: ${CC}
+ compiler flags: ${CFLAGS}
+ warning flags: ${WARN_CFLAGS}
+"