summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ce63954..c01c037 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,17 +1,17 @@
-bin_PROGRAMS = gcalctool gcalccmd
+bin_PROGRAMS = mate-calc mate-calc-cmd
INCLUDES = \
- -DUI_DIR=\""$(datadir)/gcalctool"\" \
+ -DUI_DIR=\""$(datadir)/mate-calc"\" \
-DVERSION=\""$(VERSION)"\" \
-DLOCALE_DIR=\""$(localedir)"\" \
-DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
$(WARN_CFLAGS) \
- $(GCALCTOOL_CFLAGS)
+ $(MATE_CALC_CFLAGS)
-gcalctool_SOURCES = \
+mate_calc_SOURCES = \
currency.c \
currency.h \
- gcalctool.c \
+ mate-calc.c \
math-buttons.c \
math-buttons.h \
math-display.c \
@@ -42,11 +42,11 @@ gcalctool_SOURCES = \
unittest.c \
unittest.h
-gcalctool_LDADD = \
- $(GCALCTOOL_LIBS)
+mate_calc_LDADD = \
+ $(MATE_CALC_LIBS)
-gcalccmd_SOURCES = \
- gcalccmd.c \
+mate_calc_cmd_SOURCES = \
+ mate-calc-cmd.c \
mp.c \
mp-convert.c \
mp-binary.c \
@@ -55,8 +55,8 @@ gcalccmd_SOURCES = \
mp-equation-parser.c \
mp-equation-lexer.c
-gcalccmd_LDADD = \
- $(GCALCCMD_LIBS) \
+mate_calc_cmd_LDADD = \
+ $(MATE_CALC_CMD_LIBS) \
-lm
CLEANFILES = \
@@ -78,12 +78,12 @@ mp-equation-parser.o: mp-equation-lexer.h
mp-equation-lexer.o: mp-equation-parser.h
mp-equation.c: mp-equation-lexer.h mp-equation-parser.h
-# Install a symlink between gcalctool and mate-calculator
+# Install a symlink between mate-calc and mate-calculator
install-exec-hook:
test -e "$(DESTDIR)$(bindir)/mate-calculator" \
- || (cd "$(DESTDIR)$(bindir)" && ln -s gcalctool mate-calculator)
+ || (cd "$(DESTDIR)$(bindir)" && ln -s mate-calc mate-calculator)
-# Remove the symlink between gcalctool and mate-calculator
+# Remove the symlink between mate-calc and mate-calculator
uninstall-local:
test -h "$(DESTDIR)$(bindir)/mate-calculator" \
&& rm -f "$(DESTDIR)$(bindir)/mate-calculator"
@@ -95,5 +95,5 @@ EXTRA_DIST = \
DISTCLEANFILES = \
Makefile.in
-test: gcalctool
- ./gcalctool -u
+test: mate-calc
+ ./mate-calc -u