summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-15 08:26:24 -0800
committerStefano Karapetsas <[email protected]>2012-11-15 08:26:24 -0800
commit86a51f1ba55208272a50e17ac94f745907131758 (patch)
tree93d19d85feadd31f2027f09557447998ebd42bda /Makefile.am
parent30ec51cebbfaa251bff071e39ab777af012cb015 (diff)
parent39d84d1c8a3ff07d20126f7220b7a3bfec5e306a (diff)
downloadmate-desktop-86a51f1ba55208272a50e17ac94f745907131758.tar.bz2
mate-desktop-86a51f1ba55208272a50e17ac94f745907131758.tar.xz
Merge pull request #36 from jasmineaura/develop
Properly support GTK3, simplify GTK2 compat, and some fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 217eb8a..c0d5b64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,4 @@
-SUBDIRS = \
- po \
- libmate-desktop \
- docs \
- man \
- schemas
+SUBDIRS = libmate-desktop man docs po schemas
if MATE_ABOUT_ENABLED
SUBDIRS += mate-about
@@ -14,10 +9,13 @@ endif
ACLOCAL_AMFLAGS = -I m4
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-scrollkeeper
+
if MATE_ABOUT_ENABLED
-versiondir=$(datadir)/mate-about
-version_DATA=mate-version.xml
+versiondir = $(datadir)/mate-about
+version_DATA = mate-version.xml
endif
+
@INTLTOOL_XML_RULE@
EXTRA_DIST = \
@@ -27,8 +25,6 @@ EXTRA_DIST = \
mate-version.xml.in.in \
mate-doc-utils.make
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-scrollkeeper
-
CLEANFILES = \
$(version_DATA)