summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e3be0d..4d39482 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ SUBDIRS = \
theme_in_files = index.theme.in.in
theme_DATA = $(theme_in_files:.theme.in.in=.theme)
-THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status")
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable-up-to-32/status")
%.theme.in: %.theme.in.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/mate/##g'`"; \
@@ -17,6 +17,8 @@ THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `
sizefull="`dirname $$dir`"; \
if test "$$sizefull" = "scalable"; then \
size="16"; \
+ elif test "$$sizefull" = "scalable-up-to-32"; then \
+ size="16"; \
else \
size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
fi; \
@@ -60,6 +62,10 @@ THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `
echo "MinSize=8" >> $@; \
echo "MaxSize=512" >> $@; \
echo "Type=Scalable" >> $@; \
+ elif test "$$sizefull" = "scalable-up-to-32"; then \
+ echo "MinSize=16" >> $@; \
+ echo "MaxSize=32" >> $@; \
+ echo "Type=Scalable" >> $@; \
elif test "$$size" = "256"; then \
echo "MinSize=56" >> $@; \
echo "MaxSize=512" >> $@; \