summaryrefslogtreecommitdiff
path: root/mate/48x48/categories/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate/48x48/categories/Makefile.am')
-rw-r--r--mate/48x48/categories/Makefile.am119
1 files changed, 119 insertions, 0 deletions
diff --git a/mate/48x48/categories/Makefile.am b/mate/48x48/categories/Makefile.am
new file mode 100644
index 0000000..d8cac0d
--- /dev/null
+++ b/mate/48x48/categories/Makefile.am
@@ -0,0 +1,119 @@
+NULL =
+
+png_icons = \
+ applications-accessories.png \
+ applications-development.png \
+ applications-engineering.png \
+ applications-games.png \
+ applications-graphics.png \
+ applications-internet.png \
+ applications-multimedia.png \
+ applications-office.png \
+ applications-other.png \
+ applications-science.png \
+ applications-system.png \
+ applications-utilities.png \
+ preferences-desktop.png \
+ preferences-desktop-peripherals.png \
+ preferences-desktop-personal.png \
+ preferences-other.png \
+ preferences-system.png \
+ preferences-system-network.png \
+ $(NULL)
+
+applications-accessories.png: ../../../src/applications-accessories.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=294:200:351:248 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-development.png: ../../../src/applications-development.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:200:344:248 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-engineering.png: ../../../src/applications-engineering.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=295:202:343:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-games.png: ../../../src/applications-games.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:203:344:251 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-graphics.png: ../../../src/applications-graphics.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-internet.png: ../../../src/applications-internet.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-multimedia.png: ../../../src/applications-multimedia.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-office.png: ../../../src/applications-office.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=295:202:343:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-other.png: ../../../src/applications-other.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=295:202:343:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-science.png: ../../../src/applications-science.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-system.png: ../../../src/applications-system.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+applications-utilities.png: ../../../src/applications-utilities.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=297:202:345:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-desktop.png: ../../../src/preferences-desktop.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-desktop-peripherals.png: ../../../src/preferences-desktop-peripherals.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:203:344:251 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-desktop-personal.png: ../../../src/preferences-desktop-personal.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-other.png: ../../../src/preferences-other.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:203:344:251 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-system.png: ../../../src/preferences-system.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+preferences-system-network.png: ../../../src/computers.svg
+ @echo " "$@
+ @inkscape -z $^ --export-area=296:202:344:250 -w=48 -h=48 -e=$@ 1> /dev/null
+ @mogrify -quiet -strip $@
+
+.PHONY: build-png-icons-local clean-png-icons-local
+build-png-icons-local: $(png_icons)
+
+clean-png-icons-local:
+ @echo " Cleaning icons..."
+ @rm -f $(png_icons)