summaryrefslogtreecommitdiff
path: root/mate/scalable-up-to-32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate/scalable-up-to-32/Makefile.am')
-rw-r--r--mate/scalable-up-to-32/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/mate/scalable-up-to-32/Makefile.am b/mate/scalable-up-to-32/Makefile.am
new file mode 100644
index 0000000..6110ac5
--- /dev/null
+++ b/mate/scalable-up-to-32/Makefile.am
@@ -0,0 +1,23 @@
+themedir = $(datadir)/icons/mate/scalable-up-to-32
+
+install-data-local:
+ $(mkdir_p) $(DESTDIR)$(themedir); \
+ for dir in `cd $(top_srcdir)/mate/scalable-up-to-32 && find . -type d | sed s/.//`; do \
+ $(mkdir_p) $(DESTDIR)$(themedir)$$dir; \
+ done; \
+ for file in `cd $(top_srcdir)/mate/scalable-up-to-32 && find . -name "*.svg" | sed s@./@/@`; do \
+ $(install_sh_DATA) $(top_srcdir)/mate/scalable-up-to-32$$file $(DESTDIR)$(themedir)/$$file; \
+ done;
+
+uninstall-local:
+ if [ -d "$(DESTDIR)$(themedir)" ]; then \
+ cd $(DESTDIR)$(themedir); \
+ for file in `find . -name *.svg | sed s@./@/@`; do \
+ rm -f $(DESTDIR)$(themedir)$$file; \
+ done; \
+ fi
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ Makefile
+