summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-23 22:59:38 +0100
committerStefano Karapetsas <[email protected]>2011-12-23 22:59:38 +0100
commitc3b4e76655aa6b675ba01f5af12ff375a8cd2a8c (patch)
tree75184910d196fafd90dcd2a53bf0179c07120307 /Makefile.am
downloadmate-indicator-applet-c3b4e76655aa6b675ba01f5af12ff375a8cd2a8c.tar.bz2
mate-indicator-applet-c3b4e76655aa6b675ba01f5af12ff375a8cd2a8c.tar.xz
import from Mate-Extra repository
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..dd622d3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+
+SUBDIRS = \
+ src \
+ data \
+ po
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+DISTCLEANFILES = \
+ indicator-applet-*.tar.gz \
+ gtk-doc.make
+
+EXTRA_DIST = \
+ COPYING.LGPL
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi